CodeForces 1251A --- Broken Keyboard

【CodeForces 1251A --- Broken Keyboard 】

Description

Recently Polycarp noticed that some of the buttons of his keyboard are malfunctioning. For simplicity, we assume that Polycarp’s keyboard contains 26 buttons (one for each letter of the Latin alphabet). Each button is either working fine or malfunctioning.

To check which buttons need replacement, Polycarp pressed some buttons in sequence, and a string s appeared on the screen. When Polycarp presses a button with character c, one of the following events happened:

if the button was working correctly, a character c appeared at the end of the string Polycarp was typing;
if the button was malfunctioning, two characters c appeared at the end of the string.
For example, suppose the buttons corresponding to characters a and c are working correctly, and the button corresponding to b is malfunctioning. If Polycarp presses the buttons in the order a, b, a, c, a, b, a, then the string he is typing changes as follows: a → abb → abba → abbac → abbaca → abbacabb → abbacabba.

You are given a string s which appeared on the screen after Polycarp pressed some buttons. Help Polycarp to determine which buttons are working correctly for sure (that is, this string could not appear on the screen if any of these buttons was malfunctioning).

You may assume that the buttons don’t start malfunctioning when Polycarp types the string: each button either works correctly throughout the whole process, or malfunctions throughout the whole process.

Input

The first line contains one integer t (1≤t≤100) — the number of test cases in the input.

Then the test cases follow. Each test case is represented by one line containing a string s consisting of no less than 1 and no more than 500 lowercase Latin letters.

Output

For each test case, print one line containing a string res. The string res should contain all characters which correspond to buttons that work correctly in alphabetical order, without any separators or repetitions. If all buttons may malfunction, res should be empty.

Sample Input

4
a
zzaaz
ccff
cbddbb

Sample Output

a
z

bc

解体思路:坏的按键会出现2次,好的按键出现1次,一开始想的是只要统计字母的所有出现次数,如果是奇数那么就是好的按键,仔细一想发现是错的,如果出现asssaaa,那么就会出错,那么应该统计的是连续的一段相同字母的个数,如果是奇数则是正确的。

AC代码:

#include <iostream>
#include <cstring>
#include <string>
using namespace std;
int main()
{
    string str;
    int n;
    int num[1005];
    cin>>n;
    while(n--)
    {
        int cnt=1;
        memset(num,0,sizeof num);
        cin>>str;
        for(int i=1;i<=str.length();i++)
        {
            if(str[i]==str[i-1])    
                cnt++;
            else
            {
                if(cnt%2==1)
                    num[str[i-1]-'a']=1;
                cnt=1;
            }
        }
        for(int i=0;i<26;i++)
        {
            if(num[i]==1)
                cout<<char(i+'a');
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/lovelcy/p/11758173.html