【CodeForces 1249B2 --- Books Exchange (hard version)】

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_41879343/article/details/102695515

@[TOC](【CodeForces 1249B2 — Books Exchange (hard version)】)
Description

The only difference between easy and hard versions is constraints.

There are n kids, each of them is reading a unique book. At the end of any day, the i-th kid will give his book to the pi-th kid (in case of i=pi the kid will give his book to himself). It is guaranteed that all values of pi are distinct integers from 1 to n (i.e. p is a permutation). The sequence p doesn’t change from day to day, it is fixed.

For example, if n=6 and p=[4,6,1,3,5,2] then at the end of the first day the book of the 1-st kid will belong to the 4-th kid, the 2-nd kid will belong to the 6-th kid and so on. At the end of the second day the book of the 1-st kid will belong to the 3-th kid, the 2-nd kid will belong to the 2-th kid and so on.

Your task is to determine the number of the day the book of the i-th child is returned back to him for the first time for every i from 1 to n.

Consider the following example: p=[5,1,2,4,3]. The book of the 1-st kid will be passed to the following kids:

  • after the 1-st day it will belong to the 5-th kid,
  • after the 2-nd day it will belong to the 3-rd kid,
  • after the 3-rd day it will belong to the 2-nd kid,
  • after the 4-th day it will belong to the 1-st kid.

So after the fourth day, the book of the first kid will return to its owner. The book of the fourth kid will return to him for the first time after exactly one day.

You have to answer q independent queries.

Input

The first line of the input contains one integer q (1≤q≤1000) — the number of queries. Then q queries follow.

The first line of the query contains one integer n (1≤n≤2⋅105) — the number of kids in the query. The second line of the query contains n integers p1,p2,…,pn (1≤pi≤n, all pi are distinct, i.e. p is a permutation), where pi is the kid which will get the book of the i-th kid.

It is guaranteed that ∑n≤2⋅105 (sum of n over all queries does not exceed 2⋅105).

Output

For each query, print the answer on it: n integers a1,a2,…,an, where ai is the number of the day the book of the i-th child is returned back to him for the first time in this query.

Sample Input

6
5
1 2 3 4 5
3
2 3 1
6
4 6 2 1 5 3
1
1
4
3 4 1 2
5
5 1 2 4 3

Sample Output

1 1 1 1 1
3 3 3
2 3 3 2 1 3
1
2 2 2 2
4 4 4 1 4

解题思路

根据题意可知如果1->3->4->1,那么134走到本身都需要4步,所以再找第一条路需要走的步数时,可以将路上遇见的所有点所需的步数全部得出。
只需用一个队列(或者栈),将路上遇见的所有点全部存进去,队列(或者栈)中元素个数就是步数,然后一个一个的赋值。

AC代码:

#include <iostream>
#include <queue>
using namespace std;
const int MAXN = 200005;
int arr[MAXN],ans[MAXN];

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    int T;
    cin >> T;
    while(T--)
    {
        int n;
        queue<int> q;
        cin >> n;
        for(int i=1;i<=n;i++) cin >> arr[i],ans[i]=0;
        for(int i=1;i<=n;i++)
        {
            if(ans[i]) continue;
            int pos=i;
            do{
                q.push(pos);
                pos=arr[pos];
            }while(pos!=i);
            int cnt=q.size();
            while(!q.empty())
            {
                ans[q.front()]=cnt;
                q.pop();
            }
        }
        for(int i=1;i<=n;i++)
            cout << ans[i] << (i==n?'\n':' ');
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/102695515