Fishing Master(2019中国大学生程序设计竞赛(CCPC) - 网络选拔赛)

Problem Description
Heard that  eom is a fishing MASTER, you want to acknowledge him as your mentor. As everybody knows, if you want to be a MASTER's apprentice, you should pass the trial. So when you find fishing MASTER eom, the trial is as follow:

There are n fish in the pool. For the i - th fish, it takes at least ti minutes to stew(overcook is acceptable). To simplify this problem, the time spent catching a fish is kminutes. You can catch fish one at a time and because there is only one pot, only one fish can be stewed in the pot at a time. While you are catching a fish, you can not put a raw fish you have caught into the pot, that means if you begin to catch a fish, you can't stop until after k minutes; when you are not catching fish, you can take a cooked fish (stewed for no less than ti) out of the pot or put a raw fish into the pot, these two operations take no time. Note that if the fish stewed in the pot is not stewed for enough time, you cannot take it out, but you can go to catch another fish or just wait for a while doing nothing until it is sufficiently stewed.

Now eom wants you to catch and stew all the fish as soon as possible (you definitely know that a fish can be eaten only after sufficiently stewed), so that he can have a satisfying meal. If you can complete that in the shortest possible time, eom will accept you as his apprentice and say "I am done! I am full!". If you can't, eom will not accept you and say "You are done! You are fool!".

So what's the shortest time to pass the trial if you arrange the time optimally?
 
Input
The first line of input consists of a single integer  T(1T20), denoting the number of test cases.

For each test case, the first line contains two integers n(1n105),k(1k109), denoting the number of fish in the pool and the time needed to catch a fish.

the second line contains n integers, t1,t2,,tn(1ti109) ,denoting the least time needed to cook the i - th fish.
 
Output
For each test case, print a single integer in one line, denoting the shortest time to pass the trial.
 
Sample Input
2 3 5 5 5 8 2 4 3 3
 
Sample Output
23 11
Hint
Case 1: Catch the 3rd fish (5 mins), put the 3rd fish in, catch the 1st fish (5 mins), wait (3 mins), take the 3rd fish out, put the 1st fish in, catch the 2nd fish(5 mins), take the 1st fish out, put the 2nd fish in, wait (5 mins), take the 2nd fish out. Case 2: Catch the 1st fish (4 mins), put the 1st fish in, catch the 2nd fish (4 mins), take the 1st fish out, put the 2nd fish in, wait (3 mins), take the 2nd fish out.
 
 
#include <bits/stdc++.h>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
typedef long long ll;
using namespace std;
const int INT=1e6+5;
#define lson rt<<1, l, m  
#define rson rt<<1|1, m+1, r
#define read(x) scanf("%d",&x)
#define lread(x) scanf("%lld",&x);
#define pt(x) printf("%d\n",(x))
#define cn cin>>
#define ct cout<<
#define en <<endl
#define rep(j,k) for (int i = (int)(j); i <= (int)(k); i++)
#define mem(s,t) memset(s,t,sizeof(s))
#define re return 0;
ll a[100000+5],b[10000+5];
priority_queue<ll>q1,q2;
int main()
{
    ll t,n,k,m;
    //cn t;
    read(t);
    while(t--)
    {
        //cn n>>k;
        scanf("%lld %lld",&n,&k);
        rep(1,n) lread(a[i]);//cn a[i];
        sort(a+1,a+1+n);

        for(int i=n;i>=1;i--)
        {
            if(!q1.empty())
            {
                int x=q1.top();
                q1.pop();
                if(x>k)
                    q1.push( x-k );
            }
            q1.push(a[i]);
        }
        ll sum=n*k;
        while(!q1.empty())
        {
            sum+=q1.top(); q1.pop();
        }
        printf("%lld\n",sum);
        //ct sum en;
        
    }
    re
}

猜你喜欢

转载自www.cnblogs.com/Shallow-dream/p/11415578.html