POJ 1989(双权值并查集)

Navigation Nightmare
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 8503   Accepted: 3062
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 
           F1 --- (13) ---- F6 --- (9) ----- F3

| |
(3) |
| (7)
F4 --- (20) -------- F2 |
| |
(2) F5
|
F7

Being an ASCII diagram, it is not precisely to scale, of course. 

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
... 

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

Input

* Line 1: Two space-separated integers: N and M


* Lines 2..M+1: Each line contains four space-separated entities, F1,
F2, L, and D that describe a road. F1 and F2 are numbers of
two farms connected by a road, L is its length, and D is a
character that is either 'N', 'E', 'S', or 'W' giving the
direction of the road from F1 to F2.

* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's
queries

* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob
and contains three space-separated integers: F1, F2, and I. F1
and F2 are numbers of the two farms in the query and I is the
index (1 <= I <= M) in the data after which Bob asks the
query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

queries. Each line should contain either a distance
measurement or -1, if it is impossible to determine the
appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 
 
题意:第一行输入n,m。表示n个点,m个关系。接下来m行每行三个整数,x,y,len,一个字符c。表示y在x的c方向,长度为len。
  接下来输入k,表示又来了k个询问,a,b,state。表示在state状态时候,输出点a和点b的曼哈顿距离
思路:权值用d1,d2数组来保存,d1用来存E和W(E则为正,W为负)。d2存N和S(N正S负)
   注意k组询问的state不一定是从小到大的,所以要提前排序,之后输出的时候再排序排回来
  曼华顿距离 = abs(d1[x] - d1[y]) + abs(d2[x] - d2[y]);(这个之前推错了wa了)推错的式子在代码里被注释了的
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <vector>
//const int maxn = 1e5+5;
#define ll long long
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}

#define MAX INT_MAX
#define FOR(i,a,b) for( int i = a;i <= b;++i)
#define bug cout<<"--------------"<<endl
using namespace std;
int fa[41000],d1[41000],d2[41000];

struct node
{
    int l,r;
    int len;
    char c;
}v[41000];
struct query
{
    int a,b;
    int state;
    int nub,cun; //nub用来进行第二次sort,cun是存答案的
}q[41000];
bool cmp(query x,query y)
{
    return x.state < y.state;
}
bool cmp2(query x,query y)
{
    return x.nub < y.nub;
}
int Find(int x)
{
    if(x == fa[x]) return x;
    int root = Find(fa[x]);
    d1[x] += d1[fa[x]];
    d2[x] += d2[fa[x]];
    return fa[x] = root;
}
void solve(int x,int y,int len,char c)
{
    int fx = Find(x),fy = Find(y);
    fa[fy] = fx;

    if(c == 'E') {
        d1[fy] = d1[x] + len - d1[y];
        d2[fy] = d2[x]  - d2[y];
    }

    else if(c == 'W') {
        d1[fy] = d1[x] - len - d1[y];
        d2[fy] = d2[x]  - d2[y];
    }
    else if(c == 'N'){
        d1[fy] = d1[x] - d1[y];
        d2[fy] = d2[x] + len  - d2[y];
    }
    else if(c == 'S'){
        d1[fy] = d1[x] - d1[y];
        d2[fy] = d2[x] - len  - d2[y];
    }
}
int ask(int x,int y)
{

    int fx = Find(x);
    int fy = Find(y);   
    if(fx != fy) return -1;
    int temp = 0;
    temp += abs(d1[x] - d1[y]) + abs(d2[x] - d2[y]);
//    if(d1[x] * d1[y] > 0) temp += abs(d1[x] - d1[y]);
//    else temp += abs(d1[x]) + abs(d1[y]);
//    if(d2[x] * d2[y] > 0) temp += abs(d2[x] - d2[y]);
//    else temp += abs(d2[x]) + abs(d2[y]);
    return temp;
}
int main()
{
//   freopen("C:\\Users\\方瑞\\Desktop\\input.txt","r",stdin);
//    freopen("C:\\Users\\方瑞\\Desktop\\output.txt","w",stdout);
    int n,m,k,tail;
    scanf("%d%d",&n,&m);
    FOR(i,1,n) fa[i] = i;
    FOR(i,1,m) scanf("%d%d%d %c",&v[i].l,&v[i].r,&v[i].len,&v[i].c);
    scanf("%d",&k);
    FOR(i,1,k) {
        scanf("%d%d%d",&q[i].a,&q[i].b,&q[i].state);
        q[i].nub = i;
    }
    sort(q+1,q+1+k,cmp);
    tail = 1;
    for(int i=1;i<=m;++i)
    {
        int l = v[i].l;
        int r = v[i].r;
        char c = v[i].c;
        int len  = v[i].len;
        solve(l,r,len,c);
        while(q[tail].state <= i && tail <= k)
        {

            int x = q[tail].a;
            int y = q[tail].b;
            q[tail].cun = ask(x,y);
            tail++;
        }
    }
    sort(q+1,q+1+k,cmp2);
    FOR(i,1,k) printf("%d\n",q[i].cun);

}
 

猜你喜欢

转载自www.cnblogs.com/jrfr/p/11409737.html