Simple Library Management System HDU - 1497(图书管理系统)

Problem Description

 After AC all the hardest problems in the world , the ACboy 8006 now has nothing to do . One day he goes to an old library to find a part-time job .It is also a big library which has N books and M users.The user's id is from 1 to M , and the book id is from 1 to N . According to the library rules , every user are only allowed to borrow 9 books .But what surprised him is that there is no computer in the library , and everything is just recorded in paper ! How terrible , I must be crazy after working some weeks , he thinks .So he wants to change the situation . 

In the other hand , after 8006's fans know it , they all collect money and buy many computers for the library . 

Besides the hardware , the library needs a management program . Though it is just a piece of cake for 8006 , the library turns to you , a excellent programer,for help . 

What they need is just a simple library management program . It is just a console program , and have only three commands : Borrow the book , Return the book , Query the user . 

1.The Borrow command has two parameters : The user id and the book id 
The format is : "B ui bi" (1<=ui<=M , 1<=bi<=N) 
The program must first check the book bi wether it's in the library . If it is not , just print "The book is not in the library now" in a line . 
If it is , then check the user ui . 
If the user has borrowed 9 books already, print "You are not allowed to borrow any more" . 
Else let the user ui borrow the book , and print "Borrow success". 

2.The Return command only has one parameter : The book id 
The format is : "R bi" (1<=bi<=N) 
The program must first check the book bi whether it's in the library . If it is , just print "The book is already in the library" . Otherwise , you can return the book , and print "Return success".

3.The Query command has one parameter : The user id 
The format is : "Q ui" (1<=ui<=M) 
If the number of books which the user ui has borrowed is 0 ,just print "Empty" , otherwise print the books' id which he borrows in increasing order in a line.Seperate two books with a blank.

Input

The input file contains a series of test cases . Please process to the end of file . The first line contains two integers M and N ( 1<= M <= 1000 , 1<=N<=100000),the second line contains a integer C means the number of commands(1<=C<=10000). Then it comes C lines . Each line is a command which is described above.You can assum all the books are in the library at the beginning of each cases.

Output

For each command , print the message which described above . 
Please output a blank line after each test. 
If you still have some questions , see the Sample 

Sample Input

5 10
9
R 1
B 1 5
B 1 2
Q 1
Q 2
R 5
Q 1
R 2
Q 1
5 10
9
R 1
B 1 5
B 1 2
Q 1
Q 2
R 5
Q 1
R 2
Q 1

Sample Output

The book is already in the library
Borrow success
Borrow success
2 5
Empty
Return success
2
Return success
Empty

The book is already in the library
Borrow success
Borrow success
2 5
Empty
Return success
2
Return success
Empty

//Huge input, the function scanf() may work better than cin

Hint

Hint

纯粹的模拟题

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int book[101000];
struct node
{
    int x[10];
    int y;
} p[1010];
int main()
{
    int n,m,b,u;
    char a;
    while(cin>>n>>m)
    {
        memset(book,0,sizeof(book));
        for(int i=0; i<=n; i++)
            p[i].y=0;
        int t;
        cin>>t;
        while(t--)
        {
            cin>>a;
            if(a=='B')
            {
                cin>>u>>b;
                if(book[b])
                    puts("The book is not in the library now");
                else if(p[u].y>=9)
                    puts("You are not allowed to borrow any more");
                else
                {
                    p[u].x[p[u].y++]=b;
                    book[b]=u;
                    puts("Borrow success");
                }
            }
            else if(a=='R')
            {
                cin>>b;
                if(book[b]==0)
                    puts("The book is already in the library");
                else
                {
                    int poit;
                    u=book[b];
                    book[b]=0;
                    for(int i=0; i<p[u].y; i++)
                    {
                        if(p[u].x[i]==b)
                        {
                            poit=i;
                            break;
                        }
                    }
                    for(int i=poit; i<p[u].y-1; i++)
                        p[u].x[i]=p[u].x[i+1];
                    p[u].y--;
                    puts("Return success");
                }
            }
            else if(a=='Q')
            {
                cin>>u;
                if(p[u].y==0)
                    puts("Empty");
                else
                {
                    int b[10];
                    for(int i=0; i<p[u].y; i++)
                        b[i]=p[u].x[i];
                    sort(b,b+p[u].y);
                    for(int i=0; i<p[u].y; i++)
                    {
                        if(i==0)
                            cout<<b[i];
                        else
                            cout<<" "<<b[i];
                    }
                    cout<<endl;

                }
            }
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/dwj-2019/p/11364791.html