[kuangbin带你飞]专题十二 基础DP1 C - Monkey and Banana HDU - 1069

C - Monkey and Banana

HDU - 1069

题目链接:https://vjudge.net/contest/68966#problem/C

题目:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

InputThe input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
题意:给你n个长方体的长宽高,要求上一个的长方体要比底下的长方体的长宽都要小,问能叠加多高
思路:见代码

//
// Created by hanyu on 2019/8/4.
//
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include<math.h>
#include<map>
using namespace std;
typedef long long ll;
const int maxn=1000+7;
struct Node{
    int x,y,z;
    bool operator<(const Node &other)const{
        return this->x<other.x;//x,y,z,存长高宽,再将长排序
    }
}node[maxn];
int main()
{
    int n;
    int casee=0;
    while(~scanf("%d",&n)&&n)
    {
        int high[maxn];
        memset(high,0,sizeof(high));
        int num[3];
        int k=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&num[0],&num[1],&num[2]);
            sort(num,num+3);//将这长宽高三个数排序一下,重新分配一下长宽高
            node[k].x=num[2];
            node[k].y=num[1];
            node[k++].z=num[0];//使得长要比宽长,这样后面判断长比邻接的长方体长宽时方便
            node[k].x=num[2];
            node[k].y=num[0];
            node[k++].z=num[1];
            node[k].x=num[1];
            node[k].y=num[0];
            node[k++].z=num[2];
        }
        sort(node,node+k);//这时候再把所有状态下的长方体的长排完序
        int hightmax=0;
        for(int i=0;i<k;i++)
        {
            for(int j=i-1;j>=0;j--)
            {
                if(node[i].x>node[j].x&&node[i].y>node[j].y&&high[i]<high[j])
                    high[i]=high[j];
            }
            high[i]+=node[i].z;
            if(hightmax<high[i])
                hightmax=high[i];
        }
        printf("Case %d: maximum height = %d\n",++casee,hightmax);

    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/Vampire6/p/11298413.html