Cooking Competition

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_23320955/article/details/79356262

Cooking Competition

题目解析

初始化两个数组 a[] = {1, 0, 1, -1}; b[] = {0, 1, 1, -1}; 输入数字减一为数组下标,sum累加比较即得答案

题目描述

“Miss Kobayashi’s Dragon Maid” is a Japanese manga series written and illustrated by Coolkyoushinja. An anime television series produced by Kyoto Animation aired in Japan between January and April 2017.

In episode 8, two main characters, Kobayashi and Tohru, challenged each other to a cook-off to decide who would make a lunchbox for Kanna’s field trip. In order to decide who is the winner, they asked n people to taste their food, and changed their scores according to the feedback given by those people.

There are only four types of feedback. The types of feedback and the changes of score are given in the following table.

Type Feedback Score Change (Kobayashi) Score Change (Tohru)
1 Kobayashi cooks better +1 0
2 Tohru cooks better 0 +1
3 Both of them are good at cooking +1 +1
4 Both of them are bad at cooking -1 -1

Given the types of the feedback of these n people, can you find out the winner of the cooking competition (given that the initial score of Kobayashi and Tohru are both 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases. For each test case:

The first line contains an integer n (1 ≤ n ≤ 20), its meaning is shown above.

The next line contains n integers a1, a2, … , an (1 ≤ ai ≤ 4), indicating the types of the feedback given by these n people.

Output

For each test case output one line. If Kobayashi gets a higher score, output “Kobayashi” (without the quotes). If Tohru gets a higher score, output “Tohru” (without the quotes). If Kobayashi’s score is equal to that of Tohru’s, output “Draw” (without the quotes).

Sample Input

2
3
1 2 1
2
3 4

Sample Output

Kobayashi
Draw

Hint

For the first test case, Kobayashi gets 1 + 0 + 1 = 2 points, while Tohru gets 0 + 1 + 0 = 1 point. So the winner is Kobayashi.

For the second test case, Kobayashi gets 1 - 1 = 0 point, while Tohru gets 1 - 1 = 0 point. So it’s a draw.

AC代码

#include <cstdio>
#include <iostream>
using namespace std;

int main()
{
    int a[] = {1, 0, 1, -1};
    int b[] = {0, 1, 1, -1};
    int t;
    cin >> t;
    while(t--) {
        int n, flag, suma = 0, sumb = 0;
        cin >> n;
        while(n--) {
            cin >> flag;
            suma += a[flag - 1];
            sumb += b[flag - 1];
        }
        if(suma > sumb)
            cout << "Kobayashi" <<endl;
        else if(suma < sumb)
            cout << "Tohru" << endl;
        else
            cout << "Draw" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_23320955/article/details/79356262