PAT乙级真题——1004 成绩排名(C++版本)

1004 成绩排名

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

完整代码(C++)如下:

#include<iostream>

using namespace std;

//student类
class student{
	public:
		char name[11];
		char xuehao[11];
		int score;
};

//主函数
int main()
{
	int n;
	cin>>n;

//new一个对象
	student* stu = new student[n];

//输入n个学生
	for(int i = 0;i<n;i++)
	{
		cin>>stu[i].name>>stu[i].xuehao>>stu[i].score;
	 } 

	int max=stu[0].score;
	int min=stu[0].score;
	int count1=0,count2=0;

//按成绩进行排序
	for(int i= 1;i<n;i++)
	{
		if(stu[i].score>max)
		{
			max = stu[i].score;
			count1 = i;
		}
		if(stu[i].score<min)
		{
			min = stu[i].score;
			count2 = i;
		}
	}

//输出第一名第二名学生信息
	cout<<stu[count1].name<<" "<<stu[count1].xuehao<<endl;
	cout<<stu[count2].name<<" "<<stu[count2].xuehao<<endl;
	return 0;
}

 

猜你喜欢

转载自blog.csdn.net/qq_42415326/article/details/94480234
今日推荐