A - Playground

原文链接: http://www.cnblogs.com/zhangying/p/3923928.html

My kid's school cleared a large field on their property recently to convert it into a playing area.  The field is polygonal.  The school administration decided to separate the field into two areas by building a straight picket fence between the area for the older kids and the area for the younger kids.  The fence would go between two non-adjacent vertices of the polygonal field, and given the shape of the field, all such possible fences would lie strictly and entirely within the field.
Naturally, the smaller of the two areas would go to the younger kids.  So can you help the school determine what the area of the smaller play-area would be for different fence positions?
 
INPUT
The first line contains 2 numbers N denoting the number of points in the convex polygon and Q denoting the number of possible locations of straight line fences.
The next N lines contain 2 integers each. The ith line contains the integers xi yi denoting the coordinates of the ith point of the polygon. The points are given in clockwise order.
The next Q lines contain 2 integers a b denoting that a straight line fence is to be drawn connecting a and b.
 
OUTPUT
Output Q lines one corresponding to each query. For each query, output the area of the smaller region for the corresponding query truncated to 1 decimal place. Always have 1 digit after the decimal place, so if the answer is 1, output it as 1.0 instead.
 
CONSTRAINTS
4 <= N <= 50000
1 <= Q <= 50000
-20,000,000 <= x,y <= 20,000,000
0 <= a < b-1
b < N
 
SAMPLE INPUT
4 2
0 0
0 1
1 2
1 0
1 3
0 2
 
SAMPLE OUTPUT
0.5
0.5
 
EXPLANATION
The polygon is given by the points (0,0) (0,1) (1,2) (1,0).  
In the first query, we join the points (0,1) and (1,0) which leads to the 2 areas given by (0,0) (0,1) (1,0) and (0,1) (1,2) (1,0). The first triangle has an area of 0.5 and the second triangle has an area of 1. The minimum of these 2 is 0.5.
In the second query, we join the points (0,0) and (1,2) which leads to the 2 areas given by (0,0) (0,1) (1,2) and (0,0) (1,2) (1,0). The first triangle has an area of 0.5 and the second triangle has an area of 1. The minimum of these 2 is 0.5.

题意 :求被两点分割的凸包面积的较小值    题意已经给出顺时针啦

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>

using namespace std;

#define N 50005

struct Point
{
    double x, y;
    void read()
    {
        scanf("%lf%lf",&x,&y);
    }

} p[N];

double area(Point p0, Point p1, Point p2)
{
    return fabs((p1.x-p0.x)*(p2.y-p0.y)*1.0-(p1.y-p0.y)*(p2.x-p0.x)*1.0)/2.0;
}

int main()
{
    double pol[N], res;
    int n, q, a, b;
    scanf("%d %d",&n, &q);
    for(int i = 0; i < n; i++)
    {
        p[i].read();
        pol[i] = 0;
    }

    for(int i = 2; i < n; i++)
        pol[i] = pol[i-1] + area(p[0],p[i-1],p[i]);
    //for(int i=1;i<n;i++)
    //cout<<pol[i]<<"~~~~~~~~~~~"<<endl;


    // printf("%.1lf\n", pol[n-1]);

    for(int i = 0; i < q; i++)
    {
        scanf("%d %d",&a, &b);
        //cout<<area(p[0],p[a],p[b])<<"~~~~~~~~~~"<<endl;
        if(a == 0)
        {
            res = min(pol[b],pol[n-1] - pol[b]);
        }
        else
        {
            res = pol[b] - pol[a] - area(p[0], p[a], p[b]);
            res = min(res, pol[n-1] - res);
        }
        printf("%.1lf\n",res);
    }

    return 0;
}

转载于:https://www.cnblogs.com/zhangying/p/3923928.html

猜你喜欢

转载自blog.csdn.net/weixin_30500473/article/details/94796200
今日推荐