08-图8 How Long Does It Take(25 分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:
For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible

思路:

关键路径问题,以 dist[i] 数组记录到 i 节点的最短时间。以 inDegree[i] 数组记录 i 节点的入度。
每次把入度为零的节点入队,入队之后将该节点指向的节点入度减一。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<queue>
using namespace std;
const int N = 102;
queue<int> q;
int graph[N][N] = { 0 };
int inDegree[N] = { 0 };
int dist[N];
bool topsort(int n) {
    //初始化dist 
    for (int i = 0; i < n; i++) {
        dist[i] = -1;
    }
    int cur = 0;
    for (int i = 0; i < n; i++) {
        if (inDegree[i] == 0) {
            q.push(i);
            dist[i] = 0;
            for (int j = 0; j < n; j++) {
                if (graph[i][j] > 0) {
                    dist[j] = graph[i][j];
                }
            }   
        }       
    }

    int cnt = 0;
    while (!q.empty()) {
        cur = q.front();
        q.pop();
        cnt++;
        for (int i = 0; i < n; i++) {
            if (graph[cur][i] >= 0) {
                inDegree[i]--;
                if (dist[cur] + graph[cur][i] > dist[i]) {
                    dist[i] = graph[cur][i] + dist[cur];
                }
                if (inDegree[i] == 0) {
                    q.push(i);
                }
            }
        }
    }
    if (cnt != n) {
        return false;
    }
    return true;
}
int main() {
    int n, m;
    cin >> n >> m;
    for (int i = 0;  i < n; i++) {
        for (int j = 0; j < n; j++) {
            graph[i][j] = -1;
        }
    }
    while (m--) {
        int s, e, l;
        cin >> s >> e >> l;
        graph[s][e] = l;
        inDegree[e]++;
    }

    if (!topsort(n))
        cout << "Impossible" << endl;
    else {
        int max = -1;
        for (int i = 0; i < n; i++) {
            max = max > dist[i] ? max : dist[i];
        }
        cout << max << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37513086/article/details/80079312