问题 D: Bits Reverse

版权声明:转载请注明出处 https://blog.csdn.net/qq_37708702/article/details/89856213

题目链接
题目描述

Now given two integers x and y, you can reverse every consecutive three bits in arbitrary number’s binary form (any leading zero can be taken into account) using one coin. Reversing (1,2,3) means changing it into (3,2,1).
Could you please find a way that minimize number of coins so that x = y? If you can, just output the minimum coins you need to use.

输入

The first line of input file contains only one integer T (1≤T≤10000) indicating number of test cases.
Then there are T lines followed, with each line representing one test case.
For each case, there are two integers x, y (0≤x,y≤1018) described above.

输出

Please output T lines exactly.
For each line, output Case d: (d represents the order of the test case) first. Then output the answer in the same line. If there is no way for that, print -1 instead.

样例输入
3
0 3
3 6
6 9

样例输出
Case 1: -1
Case 2: 1
Case 3: 2

提示

Sample 1: Considering following two binary string:
0: 0 …0000
3: 0 …0011
There is no way to achieve the goal.
Sample 2: Considering following two binary string:
3: 0 …0011
6: 0 …0110
You can reverse the lowest three digits in 3 so that 3 is changed into 6.
You just need to perform one reverse so that the minimum coin you need to use is 1.

题解:

将x和y分别转为二进制并存在数组里。

任意相邻三个位颠倒顺序,其实不影响中间那一位,即隔位交换。奇数位和偶数位分别考虑即可。

对于奇数位,x和y的1的个数若不相等,则无解;否则,记录x的奇数位和y的奇数位数字不同的个数 ans1

对于偶数位,x和y的1的个数若不相等,则无解;否则,记录x的偶数位和y的偶数位数字不同的个数 ans2

ans = ans1 + ans2 >> 1 即为答案

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll t,x,y,na,nb,cur1,cur2,ans,ans1,ans2,a[105],b[105];
int main(){
    scanf("%lld",&t);
    for(int i = 1;i <= t;i++){
        printf("Case %d: ",i);
        memset(a,0,sizeof a);
        memset(b,0,sizeof b);
        scanf("%lld%lld",&x,&y);
        cur1 = cur2 = 1;
        while(x){
        	a[cur1++] = x & 1;
       		x >>= 1;
    	}
    	while(y){
        	b[cur2++] = y & 1;
       		y >>= 1;
    	}
        na = nb = ans = ans1 = ans2 = 0;
        for(int i = 1;i <= 100;i += 2){ // 判断奇数位 
            if(a[i] == 1) na++;
            if(b[i] == 1) nb++;
            if(a[i] != b[i]) ans1++;
        }
        if(na != nb){
            printf("-1\n");
            continue;
        }
        na = nb = 0; 
        for(int i = 2;i <= 100;i += 2){ // 判断偶数位 
            if(a[i] == 1) na++;
            if(b[i] == 1) nb++;
            if(a[i] != b[i]) ans2++;
        }
        if(na != nb){
            printf("-1\n");
            continue;
        }
        printf("%d\n",ans1 + ans2 >> 1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37708702/article/details/89856213