zoj3954思维

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

The segments of a seven segment display are arranged as a rectangle of two vertical segments on each side with one horizontal segment on the top, middle, and bottom. If we refer the segments as the letters from a to g, it's possible to use the status of the segments which is called a seven segment code to represent a number. A standard combination of the seven segment codes is shown below.

X a b c d e f g
1 1 0 0 1 1 1 1
2 0 0 1 0 0 1 0
3 0 0 0 0 1 1 0
4 1 0 0 1 1 0 0
5 0 1 0 0 1 0 0
6 0 1 0 0 0 0 0
7 0 0 0 1 1 1 1
8 0 0 0 0 0 0 0
9 0 0 0 0 1 0 0
     
0 = on     1 = off

A seven segment code of permutation p is a set of seven segment code derived from the standard code by rearranging the bits into the order indicated by p. For example, the seven segment codes of permutation "gbedcfa" which is derived from the standard code by exchanging the bits represented by "a" and "g", and by exchanging the bits represented by "c" and "e", is listed as follows.

X g b e d c f a
1 1 0 1 1 0 1 1
2 0 0 0 0 1 1 0
3 0 0 1 0 0 1 0
4 0 0 1 1 0 0 1
5 0 1 1 0 0 0 0
6 0 1 0 0 0 0 0
7 1 0 1 1 0 1 0
8 0 0 0 0 0 0 0
9 0 0 1 0 0 0 0

We indicate the seven segment code of permutation p representing number x as cp, x. For example cabcdefg,7 = 0001111, and cgbedcfa,7 = 1011010.

Given n seven segment codes s1, s2, ... , sn and the numbers x1, x2, ... , xn each of them represents, can you find a permutation p, so that for all 1 ≤ i ≤ n, si = cp, xi holds?

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 ≤ n ≤ 9), indicating the number of seven segment codes.

For the next n lines, the i-th line contains a number xi (1 ≤ xi ≤ 9) and a seven segment code si (|si| = 7), their meanings are described above.

It is guaranteed that ∀ 1 ≤ i < j ≤ n, xi ≠ xjholds for each test case.

扫描二维码关注公众号,回复: 6113727 查看本文章

Output

For each test case, output "YES" (without the quotes) if the permutation p exists. Otherwise output "NO" (without the quotes).

Sample Input

3
9
1 1001111
2 0010010
3 0000110
4 1001100
5 0100100
6 0100000
7 0001111
8 0000000
9 0000100
2
1 1001111
7 1010011
2
7 0101011
1 1101011

Sample Output

YES
NO
YES

Hint

For the first test case, it is a standard combination of the seven segment codes.

For the second test case, we can easily discover that the permutation p does not exist, as three in seven bits are different between the seven segment codes of 1 and 7.

For the third test case, p = agbfced.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#define maxn 10
int t;
int n;
using namespace std;
struct node
{
    int row;
    char str[maxn];
}a[maxn];
int num[maxn][maxn];
void init()
{memset(num,0,sizeof(num));
    num[1][1]=num[1][4]=num[1][5]=num[1][6]=num[1][7]=1;
    num[2][3]=num[2][6]=1;
    num[3][5]=num[3][6]=1;
    num[4][1]=num[4][4]=num[4][5]=1;
    num[5][2]=num[5][5]=1;
    num[6][2]=1;
    num[7][4]=num[7][5]=num[7][6]=num[7][7]=1;
    num[9][5]=1;
}
int main()
{init();
    scanf("%d",&t);
    while(t--)
    {
        map<int,int>mp1,mp2;
        mp1.clear();
        mp2.clear();
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d%s",&a[i].row,a[i].str);
        for(int i=0;i<7;i++)
        {int temp1=0,temp2=0;
            for(int j=1;j<=n;j++)
            {
                temp2=temp2*2+a[j].str[i]-'0';
                temp1=temp1*2+num[a[j].row][i+1];
            }
            mp1[temp1]++;
            mp2[temp2]++;
        }
        if(mp1==mp2)
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89742665