PYA L1-008 求整数段和 (10 分)

版权声明:转载请附上原文链接哟! https://blog.csdn.net/weixin_44170305/article/details/89707250

上天折断了你飞翔的羽翼,你也要给自己一双翅膀!

给定两个整数A和B,输出从A到B的所有整数以及这些数的和。

输入格式:

输入在一行中给出2个整数A和B,其中−100≤A≤B≤100,其间以空格分隔。

输出格式:

首先顺序输出从A到B的所有整数,每5个数字占一行,每个数字占5个字符宽度,向右对齐。最后在一行中按Sum = X的格式输出全部数字的和X

输入样例:

-3 8

输出样例:

   -3   -2   -1    0    1
    2    3    4    5    6
    7    8
Sum = 30
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int i,t=0,sum=0,a,b;
    cin>>a>>b;
    for(i=a;i<=b;i++)
    {
        t++;
        printf("%5d",i);
        sum+=i;
        if(t%5==0)
            cout<<endl;
            else if(i==b)
                cout<<endl;
    }
    cout<<"Sum = "<<sum;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/89707250