[PAT 甲级]1017 Queueing at Bank (25 分)【模拟】

版权声明:原创博客,转载请标明出处! https://blog.csdn.net/caipengbenren/article/details/89341464

1017 Queueing at Bank (25 分)

原题链接
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
​4
​​ ) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2


计算时间差的最好的方法就是把标准格式改成以秒为单位的时间计数方法。
中止条件就是,窗口服务结束时间大于17 * 3600,或者 顾客到达时间大于17 * 3600。

但是最后一个测试点没有过,暂时觉得自己的思路没有错,先记录下来,等以后在看吧。
在这里插入图片描述


#include<iostream>
#include<vector>
#include<algorithm>
using namespace  std;
struct node {
    int st;
    int wt;
};
bool cmp (node a, node b) {
    return a.st < b.st;
}
int main () {
    int n, k, num = 0;
    double ans = 0;
    cin >> n >> k;
    vector<node >per(n);
    vector<int >win(k, 8 * 60 * 60);
    for (int i = 0; i < n; i++) {
        int h, m, s;
        scanf("%d:%d:%d %d", &h, &m, &s, &per[i].wt);
        per[i].st = h * 60 * 60 + m * 60 + s;
        per[i].wt = per[i].wt > 60 ? 60 : per[i].wt;
        per[i].wt = per[i].wt * 60;
    }
    sort(per.begin(), per.end(), cmp);
    for (int i = 0; i < n; i++, num++) {
        sort(win.begin(), win.end());
        if (win[0] > 17 * 60 * 60 || per[i].st > 17 * 60 * 60) {
            break;
        }
        if (per[i].st < win[0]) {
            ans += win[0] - per[i].st;
        }
        if (per[i].st < win[0]) {
            win[0] = win[0] + per[i].wt;
        } else {
            win[0] = per[i].st + per[i].wt;
        }
    }
    ans /= 60;
    ans /= (1.0 * num);
    printf("%.1f", ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/caipengbenren/article/details/89341464