HDU2717:CATCH THAT COW(BFS)

Catch That Cow
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22964 Accepted Submission(s): 6568

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意是一行输入n 和 k 代表农夫和牛的位置,农夫可以向前或向后走一步,或者到2*他现在位置的那个位置,问最少时间(几步)能抓到那头牛。

总结:

  1. 要多组输入!但题目没说。
  2. bfs一开始一定要 memset 那个标记数组啊! 不然就wa啊!!

下面附上ac代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <ctype.h>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;
typedef long long int ll;
int sgn[210000];
int n,k;
struct node {
    int x,step;
};
bool check(int x) {
    if(x < 0 || x > 100000) {return false;}
    if(sgn[x] == 1) {return false;}
    return true;
}
int bfs() {
    memset(sgn,0,sizeof(sgn));
    node cur,next;
    cur.x = n;
    sgn[cur.x] = 1;
    cur.step = 0;
    queue<node>q;
    q.push(cur);
    while(!q.empty()) {
        cur = q.front();
        q.pop();
        if(cur.x == k) {
            return cur.step;
        }
        next.x = cur.x + 1;
        if(check(next.x)) {
            next.step = cur.step + 1;
            sgn[next.x] = 1;
            q.push(next);
        }
        next.x = cur.x - 1;
        if(check(next.x)) {
            next.step = cur.step + 1;
            sgn[next.x] = 1;
            q.push(next);
        }
        next.x = cur.x * 2;
        if(check(next.x)) {
            next.step = cur.step + 1;
            sgn[next.x] = 1;
            q.push(next);
        }
    }
}
int main() {
    while(cin >> n >> k) {
        cout << bfs() << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43555854/article/details/86695739