flyd-路径输出字典序模版加例题

 Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

模版代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#define inf 0x3f3f3f3f
using namespace std;
int map1[1009][1009];
int b[1009];
int path[1009][1009] ;
void bfs(int u ,int v)
{
	printf("Path: %d",u);
	if(u == v)
	{
		printf("\n");
	return;	
	}
	int now = path[u][v]; 
	while(1)
	{
	printf("-->%d",now);
		if(now == v)
		{
			printf("\n");break;
		}
		
		now = path[now][v];
	}	
}//bfs路径输出
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n == 0)
		{break;}
		memset(map1,0,sizeof(map1));
		memset(path,0,sizeof(path));
		memset(b,0,sizeof(b));
		for(int i = 1;i <= n;++i)
		{
			for(int j = 1;j <= n;++j)
			{
				scanf("%d",&map1[i][j]);
				if(map1[i][j] == -1)
				{
					map1[i][j] = inf;
				}
				path[i][j] = j;
			}
		}
		for(int i = 1;i <= n;++i)
		{
			scanf("%d",&b[i]);
		}
		for(int k = 1;k <= n ;++k)
		{
			for(int i = 1;i <= n;++i)
			{
				for(int j = 1;j <= n;++j)
				{
					if(map1[i][j] == map1[i][k] + map1[k][j] + b[k])
					{
						if(path[i][j] > path[i][k])//输出字典序
						{
							path[i][j] = path[i][k];
						}
					}
					if(map1[i][j] > map1[i][k] + map1[k][j] + b[k])
					{
						map1[i][j] = map1[i][k] + map1[k][j] + b[k];//多一个权值代表过路费
						path[i][j] = path[i][k];
					}
				}
			}
		}
		int start,end;
		while(1)
		{
			scanf("%d%d",&start,&end);
			if(start == -1 || end == -1)
			{
				break;
			}
			printf("From %d to %d :\n",start,end);
			bfs(start,end);
			printf("Total cost : %d\n\n",map1[start][end]);	
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43568078/article/details/89115704