Dropping tests POJ - 2976 (01规划模板)

版权声明: https://blog.csdn.net/nucleare/article/details/88946498

Dropping tests

 POJ - 2976 

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1e3 + 7;
const double eps = 1e-8;
double a[N], b[N], c[N];
int n, k;
int check(double mid) {
	for (int i = 1; i <= n; ++i) {
		c[i] = a[i] - mid * b[i];
	}
	sort(c+1, c+n+1);
	double f = 0;
	for (int i = k+1; i <= n; ++i) {
		f += c[i];
	}
	return f >= 0 ? 1 : 0;
}
int main() {
	while (~scanf ("%d %d", &n, &k) && (n + k)) {
		for (int i = 1; i <= n; ++i) {
			scanf ("%lf", &a[i]);
		}
		for (int i = 1; i <= n; ++i) {
			scanf ("%lf", &b[i]);
		}
		double l = 0, r = 1, mid;
		while (r - l > eps) {
			mid = (l + r) /2.0;
			if (check(mid)) l = mid;
			else r = mid;
		}
		printf ("%.0f\n", l*100);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/88946498