Hakase and Nano

题目描述

Hakase and Nano are playing an ancient pebble game (pebble is a kind of rock). There are n packs of pebbles, and the i-th pack contains ai pebbles. They take turns to pick up pebbles. In each turn, they can choose a pack arbitrarily and pick up at least one pebble in this pack. The person who takes the last pebble wins.
This time, Hakase cheats. In each turn, she must pick pebbles following the rules twice continuously.
Suppose both players play optimally, can you tell whether Hakase will win?

输入

The first line contains an integer T (1≤T≤20) representing the number of test cases.
For each test case, the fi rst line of description contains two integers n(1≤n≤106) and d (d = 1 or d = 2). If d = 1, Hakase takes first and if d = 2, Nano takes first. n represents the number of pebble packs.
The second line contains n integers, the i-th integer ai (1≤ai≤109) represents the number of pebbles in the i-th pebble pack.

输出

For each test case, print “Yes” or “No” in one line. If Hakase can win, print “Yes”, otherwise, print “No”.

样例输入
2
3 1
1 1 2
3 2
1 1 2

样例输出

Yes
No

思路
当Hakase为先手时,只有在ai都等于1且n为3的倍数时, Hakase方失利,当Hakase为后手时,只有在ai都等于1且n与3的模为1或存在一个ai大于1且n与3的模小于等于1时, Hakase方失利

代码实现

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
typedef long long ll;
const int N=1000005;
const int mod=998244353;
int T,n,d;

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        int s=0;
        scanf("%d%d",&n,&d);
        for(int i=0;i<n;i++)
        {
            int temp;
            scanf("%d",&temp);
            if(temp>1) s++;
        }
        if(d==1)
        {
            if(s==0)
            {
                if(n%3==0)  printf("No\n");
                else printf("Yes\n");
            }
            else printf("Yes\n");
        }
        else
        {
            if(s==0)
            {
                if(n%3==1)  printf("No\n");
                else printf("Yes\n");
            }
            else
            {
                if(s>1) printf("Yes\n");
                else
                {
                    if(n%3<=1) printf("No\n");
                    else printf("Yes\n");
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43935894/article/details/89047138