liughtoj1341求区间内约数个数(分解素因子)

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and bdenotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

公式为(1+a1)*(1+a2)*..*(1+an)

其中ai为素数分解后指数 ,求出结果后再枚举小于b的个数,减去即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
#define maxn 1000009
int p[maxn];
int vis[maxn];
int t;

int cnt;
void init()
{
    cnt=0;
    memset(p,0,sizeof(p));
    memset(vis,0,sizeof(vis));
    vis[0]=vis[1]=1;
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
            p[cnt++]=i;
        for(int j=0;j<cnt&&i*p[j]<maxn;j++)
        {
            vis[i*p[j]]=1;
            if(i%p[j]==0)
                break;
        }
    }
}
ll solve(ll x)
{
    ll num=1;
    for(int i=0;i<cnt&&p[i]<=sqrt(x);i++)
    {
        int cc=0;
        while(x%p[i]==0)
        {
            cc++;
            x/=p[i];
        }
        num*=(cc+1);
    }
    if(x>1)
        num*=2;
    return num;
}
int main()
{init();
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        ll a,b;
        scanf("%lld%lld",&a,&b);
        if(b*b>a)
            printf("Case %d: 0\n",w);
        else
        {ll n=solve(a);
        n/=2;
        for(int i=1;i<b;i++)
            if(a%i==0)
          n--;

    printf("Case %d: %lld\n",w,n);
    }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88830187