Zombie's Treasure Chest

Some brave warriors come to a lost village. They are very lucky and find a lot of treasures and a big
treasure chest, but with angry zombies.
The warriors are so brave that they decide to defeat the zombies and then bring all the treasures
back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies
are undead and invincible.
Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the
treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only
two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with
infinite quantities. So are sapphires.
Being the priest of the warriors with the magic artifact: computer, and given the size of the chest,
the value and size of each types of gem, you should compute the maximum value of treasures our
warriors could bring back.
Input
There are multiple test cases. The number of test cases T (T ≤ 200) is given in the first line of the
input file. For each test case, there is only one line containing five integers N, S1, V1, S2, V2, denoting
the size of the treasure chest is N and the size and value of an emerald is S1 and V1, size and value of
a sapphire is S2, V2. All integers are positive and fit in 32-bit signed integers.
Output
For each test case, output a single line containing the case number and the maximum total value of all
items that the warriors can carry with the chest.
Sample Input
2
100 1 1 2 2
100 34 34 5 3
Sample Output
Case #1: 100
Case #2: 86
代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    //freopen("F:\\1234.txt","r",stdin);
    //freopen("F:\\12345.txt","w",stdout);
    int t;
    cin>>t;
    int kase=0;
    while(t--)
    {
        long long int n,s1,v1,s2,v2;
        cin>>n>>s1>>v1>>s2>>v2;
        kase++;
        cout<<"Case #"<<kase<<": ";
        long long int mn=0;
        if(s1*s2<=n)
        {
            if(s1*v2<s2*v1)
            {
                swap(s1,s2);
                swap(v1,v2);
            }
            for(int i=0;i<s2;i++)
                mn=max(i*v1+(n-i*s1)/s2*v2,mn);
        }
        else
        {
            if(s1<s2)
            {
                swap(s1,s2);
                swap(v1,v2);
            }
            for(int i=0;i<=n/s1;i++)
                mn=max(v1*i+(n-i*s1)/s2*v2,mn);
        }
        cout<<mn<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/88721170