【并查集】【水】LA3027合作网络

A very big corporation is developing its corporative network. In the beginning each of the N enterprises
of the corporation, numerated from 1 to N, organized its own computing and telecommunication center.
Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters,
each of them served by a single computing and telecommunication center as follow. The corporation
chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other
cluster B (not necessarily the center) and link them with telecommunication line. The length of the
line between the enterprises I and J is |I −J|(mod 1000). In such a way the two old clusters are joined
in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the
lengths of the lines linking an enterprise to its serving center could be changed and the end users would
like to know what is the new length. Write a program to keep trace of the changes in the organization
of the network that is able in each moment to answer the questions of the users.
Your program has to be ready to solve more than one test case.

Input

The first line of the input file will contains only the number T of the test cases. Each test will start
with the number N of enterprises (5 ≤ N ≤ 20000). Then some number of lines (no more than 200000)
will follow with one of the commands:
E I — asking the length of the path from the enterprise I to its serving center in the moment;
I I J — informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word ‘O’. The ‘I’ commands are less than N.

Output

The output should contain as many lines as the number of ‘E’ commands in all test cases with a single
number each — the asked sum of length of lines connecting the corresponding enterprise with its serving
center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

题目大意

将N个结点编号为1-N。接下来执行若干行操作:

  • I u v:将u结点的父结点设置为v,它们之间的距离公式为abs(u - v) mod 1000。
  • E u:查询u结点到它的节点的距离。

代码

package uf;

import java.io.*;

public class LA3027 {
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in), 1 << 16);
        BufferedWriter writer = new BufferedWriter(new OutputStreamWriter(System.out), 1 << 16);
        int T = Integer.parseInt(reader.readLine());
        while (T-- > 0){
            int N = Integer.parseInt(reader.readLine());
            // dist[v]储存 v到它的父结点u的距离
            // dist[v] = u 代表v的父结点是u
            int[] dist = new int[N + 1];
            int[] id = new int[N + 1];

            // 初始化
            for(int i = 1; i <= N; i++) id[i] = i;
            String line;
            String[] parm;
            while (true){
                line = reader.readLine();
                if(line.equals("O")) break;
                parm = line.split("\\s+");
                if(parm.length == 3){
                    // 更新链接和距离
                    int u = Integer.parseInt(parm[1]), v = Integer.parseInt(parm[2]);
                    id[u] = v;
                    dist[u] =  Math.abs(u - v) % 1000;
                }else{
                    int d = 0;
                    // 递归累加到根结点的距离
                    for(int x = Integer.parseInt(parm[1]); x != id[x]; x = id[x]){
                        d += dist[x];
                    }
                    writer.write(d + "\n");
                }
            }
        }
        writer.flush();
    }
}

猜你喜欢

转载自blog.csdn.net/a617976080/article/details/88734054
LA
今日推荐