PAT 1058 A+B in Hogwarts

 If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

 Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

 For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

代码

#include<cstdio>
#include<cstdlib>
using namespace std;
int main()
{
    int x,y,z,a,b,c;
    scanf("%d.%d.%d",&x,&y,&z);
    scanf("%d.%d.%d",&a,&b,&c);
    z=z+c;
    y=y+b+z/29;
    z%=29;
    x=x+a+y/17;
    y%=17;
    printf("%d.%d.%d",x,y,z);
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84994317