L1-017

L1-017 到底有多二 (15 分)
一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。

输入格式:

输入第一行给出一个不超过50位的整数N。

输出格式:

在一行中输出N犯二的程度,保留小数点后两位。

输入样例:

-13142223336

输出样例:

81.82%
#include <cstdio>
#include <iostream>
#include <string>

using namespace std;

int main()
{
    string num;
    cin >> num;
    bool neg = false; //标记是否是负数
    double value(1);
    int i(0), len = num.size(), count_two(0);
    if (num[0] == '-')
    {
        ++i;
        neg = true;
        value *= 1.5;
    }
    if ((num[len - 1] - '0') % 2 == 0)
        value *= 2;
    for ( ; i < len; ++i)
        if (num[i] == '2')
            ++count_two;
    if (neg)
        --len;
    printf("%.2f%%", count_two * 100.0 / len * value);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43231262/article/details/88582538