Seam Carving(阅读理解+dp+记录路径)

Fish likes to take photo with his friends. Several days ago, he found that some pictures of him were damaged. The trouble is that there are some seams across the pictures. So he tried to repair these pictures. He scanned these pictures and stored them in his computer. He knew it is an effective way to carve the seams of the images He only knew that there is optical energy in every pixel. He learns the following principle of seam carving. Here seam carving refers to delete through horizontal or vertical line of pixels across the whole image to achieve image scaling effect. In order to maintain the characteristics of the image pixels to delete the importance of the image lines must be weakest. The importance of the pixel lines is determined in accordance with the type of scene images of different energy content. That is, the place with the more energy and the richer texture of the image should be retained. So the horizontal and vertical lines having the lowest energy are the object of inspection. By constantly deleting the low-energy line it can repair the image as the original scene. 


For an original image G of m*n, where m and n are the row and column of the image respectively. Fish obtained the corresponding energy matrix A. He knew every time a seam with the lowest energy should be carved. That is, the line with the lowest sum of energy passing through the pixels along the line, which is a 8-connected path vertically or horizontally. 

Here your task is to carve a pixel from the first row to the final row along the seam. We call such seam a vertical seam.

Input

There several test cases. The first line of the input is an integer T, which is the number of test cases, 0<T<=30. Each case begins with two integers m, n, which are the row and column of the energy matrix of an image, (0<m,n<=100). Then on the next m line, there n integers.

Output

For each test case, print “Case #” on the first line, where # is the order number of the test case (starting with 1). Then print the column numbers of the energy matrix from the top to the bottom on the second line. If there are more than one such seams, just print the column number of the rightmost seam.

Sample Input

2
4 3
55 32 75
17 69 73
54 81 63
47 5 45
6 6
51 57 49 65 50 74
33 16 62 68 48 61
2 49 76 33 32 78
23 68 62 37 69 39
68 59 77 77 96 59
31 88 63 79 32 34

Sample Output

Case 1
2 1 1 2
Case 2
3 2 1 1 2 1

题意:给一个N*M的矩阵,让你用一条线 从第1行连到第N行(每行只能选一个元素),要求这条线所经过的元素之和最小。 
有以下规定——
1,若你选择了位置(i,j)的元素,那么下一行的元素你只能选择(i+1,j-1)、(i+1,j)、(i+1,j+1)三个之一(当然边界只能选两个)。
2,若可以找到多条  路径上元素之和最小 的线,那么你要优先选择最右边的线。
3,最后从第一行开始 输出线上元素的纵坐标。


思路:dp+记录路径

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
using namespace std;
typedef long long ll;
int dp[105][105];
int last[105][105];
const int INF=0x3f3f3f3f;
int main() {
	int T;
	scanf("%d",&T);
	for(int k=1; k<=T; k++) {
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=m; j++) {
				scanf("%d",&dp[i][j]);
			}
		}
		for(int i=n-1; i>=1; i--) {
			for(int j=1; j<=m; j++) {
				int t=INF;
				if(j-1>=1) {
					t=min(t,dp[i+1][j-1]);
					if(t==dp[i+1][j-1])
						last[i][j]=j-1;
				}
				if(j+1<=m) {
					t=min(t,dp[i+1][j+1]);
					if(t==dp[i+1][j+1])
						last[i][j]=j+1;
				}
				t=min(t,dp[i+1][j]);
				  if(t==dp[i+1][j])
					  last[i][j]=j;
				dp[i][j]+=t;
			}
		}
		printf("Case %d\n",k);
		int head=-1,t=INF;
		for(int i=1; i<=m; i++) {
			if(dp[1][i]<=t) {
				t=dp[1][i];
				head=i;
			}
		}
		printf("%d",head);
		for(int i=1; i<n; i++) {
			printf(" %d",last[i][head]);
			head=last[i][head];
		}
		printf("\n");
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/88594840