[蓝桥杯]Hello, world!

Hello, world!

时间限制: 1Sec 内存限制: 64MB 提交: 4172 解决: 2032

题目描述
This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.
输入
The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.
输出
Output the corresponding message. Note there is NOT a newline character in the end of output.
样例输入
72 101 108 108 111 44
32 119 111 114 108 100 33
样例输出
Hello, world!

解题思路

挂了几次在死循环上,还是对字符串的熟悉度不够
代码很简练,写了挺久才AC,,在下丢人了。。。。。

完整代码

#include <iostream>
 
using namespace std;
 
int main()
{
    int n;
    string str;
    while(cin >> n && n != NULL)
        str += n;
    cout << str << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/DanBo_C/article/details/88359838