南阳oj 248 BUYING FEED

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qiaoermeng/article/details/53311873

BUYING FEED
时间限制:3000 ms | 内存限制:65535 KB
难度:4
描述
Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on the X axis might have more than one store.

Farmer John starts at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store’s limit. What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution. Consider a sample where Farmer John needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:

0 1 2 3 4 5

1 1 1 Available pounds of feed
1 2 2 Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
1
2 5 3
3 1 2
4 1 2
1 1 1
样例输出
7
这道题一开始的时候,我也是没有一点思路 但是突然发现,每个商店的每个feed到达终点所花的cent是可以算出来的,然后排序,即可知道
以下附上代码:
看不懂可以留言呢,看到会及时回复的呢

#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<stack>
#include<vector>
#include<string.h>
#include<map>
#define INF 0x3f3f3f3f3f
using namespace std;
struct node
{
    int x,ge,dan,dmoney; // x是商店位置,ge是商店feed个数,dan是feed单价
} a[105];
int cmp(node a,node b)
{
    return a.dmoney<b.dmoney;    //按照单个feed所需费用从小到大排序
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int k,e,n;
        scanf("%d%d%d",&k,&e,&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].ge,&a[i].dan);
            a[i].dmoney=a[i].dan+(e-a[i].x); // 算出单个feed到达终点所需费用a[i].dmoney;
        }
        sort(a,a+n,cmp);
        int ans=0;
        for(int i=0; i<n; i++)
        {
            if(k>=a[i].ge)
            {
                k-=a[i].ge;
                ans+=a[i].ge*a[i].dmoney;             //全部买这个商店的feed
            }
            else
            {
                ans+=k*a[i].dmoney;           //只买k个
                break;
            }
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qiaoermeng/article/details/53311873