HDU - 4788 Hard Disk Drive (成都邀请赛H 水题)

HDU - 4788
Time Limit:1000MS   Memory Limit:32768KB   64bit IO Format:%I64d & %I64u

[]  [Go Back]  [Status]  

Description

  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input

  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output

  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input

 
     
2 100[MB] 1[B]
 

Sample Output

 
     
Case #1: 4.63% Case #2: 0.00%

Hint

思路:基本的区别是在第一位
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int n;
char u[8];

int main()
{
	while (scanf("%d", &n) != EOF) {
		for (int cas = 1; cas <= n; cas++) {
			scanf("%*d%s", u);
			printf("Case #%d: ", cas);
			if (u[1] == 'B')
				printf("0.00");
			else if (u[1] == 'K')
				printf("2.34");
			else if (u[1] == 'M')
				printf("4.63");
			else if (u[1] == 'G')
				printf("6.87");
			else if (u[1] == 'T')
				printf("9.05");
			else if (u[1] == 'P')
				printf("11.18");
			else if (u[1] == 'E')
				printf("13.26");
			else if (u[1] == 'Z')
				printf("15.30");
			else if (u[1] == 'Y')
				printf("17.28");
			printf("%%\n");
		}
	}
	return 0;
}



猜你喜欢

转载自www.cnblogs.com/ldxsuanfa/p/10488871.html