PAT菜鸡进化史_乙级_1027

PAT菜鸡进化史_乙级_1027

本题要求你写个程序把给定的符号打印成沙漏的形状。例如给定17个“*”,要求按下列格式打印

*****
 ***
  *
 ***
*****

所谓“沙漏形状”,是指每行输出奇数个符号;各行符号中心对齐;相邻两行符号数差2;符号数先从大到小顺序递减到1,再从小到大顺序递增;首尾符号数相等。

给定任意N个符号,不一定能正好组成一个沙漏。要求打印出的沙漏能用掉尽可能多的符号。

输入格式:

输入在一行给出1个正整数N(≤1000)和一个符号,中间以空格分隔。

输出格式:

首先打印出由给定符号组成的最大的沙漏形状,最后在一行中输出剩下没用掉的符号数。

输入样例:

19 *

输出样例:

*****
 ***
  *
 ***
*****
2

思路:

就是个找规律的事。。没啥好说的

Code:

#include <iostream>
#include <cmath>

int main(){
    using namespace std;
// input the number of total ch
    int total;
    char ch;
    cin >> total >> ch;
// calculate the height of the triangle
    int n = sqrt((total + 1) / 2);
// display the hourglass
    for (int i = 0; i < n; i++){
        for (int j = 0; j < i; j++)
            cout << ' ';
        for (int j = 0; j < 2 * n - 1 - 2 * i; j++)
            cout << ch;
        cout << endl;
    }
    for (int i = n - 2; i >= 0; i--){
        for (int j = 0; j < i; j++)
            cout << ' ';
        for (int j = 0; j < 2 * n - 1 - 2 * i; j++)
            cout << ch;
        cout << endl;
    }
    cout << total - 2 * n * n + 1;

    return 0;
}



猜你喜欢

转载自blog.csdn.net/Raccoonnn/article/details/88085965
今日推荐