带空格字符串输入:getline(cin, str);

PAT1077A
1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

**Sample Input 1:**
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
**Sample Output 1:**
nyan~
**Sample Input 2:**
3
Itai!
Ninjinnwaiyada T_T
T_T
**Sample Output 2:**
nai

#include <bits/stdc++.h>

using namespace std;

int main()
{ 
    int n;
    cin >> n;
    getchar();
    vector<string> j;
    for (int i = 0; i < n; ++i)
    {
        string temp;
        getline(cin, temp);
        // cout << temp << endl;
        j.push_back(temp);
    }
    int len = j.size();
    string res = j[0];
    for (int i = 1; i < len; ++i)
    {
        int len1 = res.length();
        int len2 = j[i].length();
        bool equal = true;
        string op = j[i];
        for (int i = len1, m = len2; i>=0 || m>=0; --i, --m)
        {
            
            if (res[i] == op[m])
                continue;
            if (res[i] != op[m])
            {
                res = res.substr(i + 1, len1);
                break;
            }
        }
    }
    if (res == "")
        cout << "nai";
    else
        cout << res;
    system("pause");
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_39742952/article/details/88074744