1155 Heap Paths (30 分) 有关堆的题

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题意:

         给你一棵完全二叉树的层序遍历,即可以得到一个堆,需要你从右子树开始镜像的输出从根到叶,并判断是大顶堆还是小顶堆还是不是堆

思路:

        dfs生成堆,并注意到达叶子结点的标志

              完全二叉树判断某个结点是否为叶子结点的标志是该节点root的左子节点的编号root*2是否大于结点总个数 n

       中间利用几个bool变量来判断是什么堆   (注意堆的根节点的数组下标一定要从1开始)

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1005;
bool max_flag=false,min_flag=false,not_flag=false;
int level[maxn];
vector<int>path;	
int n;

void dfs(int root)
{
	path.push_back(level[root]);
	if(root*2>n)//表示该结点为叶子结点
	{
		for(int i=0;i<path.size();i++)
		{
			printf("%d",path[i]);
			if(i>0)
			{
				if(path[i]<=path[i-1])
				max_flag=true;
				else if(path[i]>=path[i-1])
				min_flag=true;
				if(min_flag==true&&max_flag==true)
				not_flag=true;
			}
			if(i<path.size()-1)
			printf(" ");
			else
			printf("\n");
		}
	} 
	else
	{
		if(root*2+1<=n)//右子树先 
		dfs(root*2+1);
		if(root*2<=n)//再左子树 
		dfs(root*2);
	}
	path.pop_back();
} 
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{//注意这里要从1开始 
		scanf("%d",&level[i]);
	}
	dfs(1);//1号位进入 
	if(not_flag)
	printf("Not Heap\n");
	else
	{
		if(max_flag)
		printf("Max Heap\n");
		else if(min_flag)
		printf("Min Heap\n");	
	}	
}

猜你喜欢

转载自blog.csdn.net/qq_40916491/article/details/88026093