c ASCII码排序

Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。

Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。

Output
对于每组输入数据,输出一行,字符中间用一个空格分开。

Sample Input
qwe
asd
zxc

Sample Output
e q w
a d s
c x z

Author

代码:
#include<stdio.h>
int main()
{
char a,b,c;
while(scanf(" %c%c%c",&a,&b,&c)!=EOF)
{
if((a<b)&&(b<c))
printf("%c %c %c\n",a,b,c);
if((a<c)&&(c<b))
printf("%c %c %c\n",a,c,b);
if((b<a)&&(a<c))
printf("%c %c %c\n",b,a,c);
if((b<c)&&(c<a))
printf("%c %c %c\n",b,c,a);
if((c<a)&&(a<b))
printf("%c %c %c\n",c,a,b);
if((c<b)&&(b<a))
printf("%c %c %c\n",c,b,a);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/87940497