Buy Ticket 线段树

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243

Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.
在这里插入图片描述
大体意思就是一群人排队买票,可以插队,给了这个人来排队的时候前面那个人的位置,让你输出最后队列顺序的val值,首先要理解题意,由于插队是允许的,所以在排队时,先来的人并不一定就一定在那个位置上待到最后,所以在使用二叉树的时候应该逆序使用,晚来的先查询,同时使用一个结构体数组来记录线段树节点,其中的num记录的是当前线段树左右端之间还能放下几个人,利用这一点来排除插队的影响,这样题目就转化为了求快速求出前p[n]个空位的位置的问题。题目比较抽象,需要看懂题意才能下手
AC代码

#include<stdio.h>
#include<iostream>
using namespace std;
struct Node{
	int l,r,num;
};
struct Node node[800005];
int val[200005];
int p[200005];
int ans[200005];
void build(int n,int x,int y)
{
	node[n].l=x;
	node[n].r=y;
	node[n].num=y-x+1;
	if(x==y) return;
	int mid=(x+y)/2;
	build(n<<1,x,mid);
	build(n<<1|1,mid+1,y); 
}
int query(int n,int x)
{
	node[n].num--;
	if(node[n].l==node[n].r) return node[n].l;
	if(x<=node[n<<1].num) return query(n<<1,x);
	else return query(n<<1|1,x-node[n<<1].num);
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		build(1,1,n);
		for(int i=0;i<n;i++)
			scanf("%d %d",&p[i],&val[i]);
		for(int i=n-1;i>=0;i--)
			ans[query(1,p[i]+1)]=val[i];
		for(int i=1;i<n;i++)
			printf("%d ",ans[i]);
			printf("%d\n",ans[n]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43849505/article/details/87007880
今日推荐