PAT 甲级 1122 Hamiltonian Cycle

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87901065

1122 Hamiltonian Cycle (25 point(s))

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

经验总结:

题意就是找简单回路,首先把不符合简单回路定义的直接排除,然后再检查相邻顶点之间是否有边,没有边的也排除,剩余的就是简单回路了~

AC代码

#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int maxn=210;
int n,m;
bool G[maxn][maxn]={false},flag[maxn];
vector<int> temp;
bool judge(vector<int> temp)
{
	for(int i=0;i<temp.size()-1;++i)
		if(G[temp[i]][temp[i+1]]==false)
			return false;
	return true;
}
int main()
{
	int a,b,k,p;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;++i)
	{
		scanf("%d%d",&a,&b);
		G[a][b]=G[b][a]=1;
	}
	scanf("%d",&k);
	for(int i=0;i<k;++i)
	{
		scanf("%d",&p);
		temp.resize(p);
		memset(flag,0,sizeof(flag));
		for(int j=0;j<p;++j)
		{
			scanf("%d",&temp[j]);
			if(j!=p-1)
				flag[temp[j]]=true;
		}
		int f=1;
		if(p!=n+1||temp[0]!=temp[p-1])
			f=0;
		else
		{
			for(int j=1;j<=n;++j)
				if(flag[j]==false)
				{
					f=0;
					break;
				}
			if(f==1&&!judge(temp))
				f=0;
		}
		printf("%s",f?"YES\n":"NO\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87901065