E - 三分

https://vjudge.net/contest/279018#problem/E

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm's efficiency, she collects many datasets. 
What's more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. 



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

题目大意:

三分模板题。

有n个二次函数在同一坐标系中,求由这个图组成的最上面的二次函数的最小值。

题目分析:

从两端开始向答案逼近。求某个点的最大值。遍历所有二次函数在这个点的值,比较。

利用三分求极值。本题卡精度,eps要1e-14左右。

代码:

#include <iostream>
#include <string>
#include<algorithm>
#define eps 1e-14 
using namespace std;

double a[10005],b[10005],c[10005];int n; 
double find(double x)
{
	double maxn=a[0]*x*x+b[0]*x+c[0];
	for(int i=1;i<n;i++)
	{
		maxn=max(maxn,a[i]*x*x+b[i]*x+c[i]);
	}
	return maxn;
}
int main()
{
	int t;scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
		double l=0.0,r=1000.0,ml,rl;
		while(r>eps+l)
		{
			ml=(l+r)/2;
			rl=(ml+r)/2;
			if(find(ml)>find(rl))l=ml;
			else r=rl;
		}
		printf("%.4lf\n",find(l));
	}
}

猜你喜欢

转载自blog.csdn.net/qq_43490894/article/details/87539983
今日推荐