L2-002 链表去重

给定一个带整数键值的链表 L,你需要把其中绝对值重复的键值结点删掉。即对每个键值 K,只有第一个绝对值等于 K 的结点被保留。同时,所有被删除的结点须被保存在另一个链表上。例如给定 L 为 21→-15→-15→-7→15,你需要输出去重后的链表 21→-15→-7,还有被删除的链表 -15→15。

输入格式:

输入在第一行给出 L 的第一个结点的地址和一个正整数 N(≤,为结点总数)。一个结点的地址是非负的 5 位整数,空地址 NULL 用 − 来表示。

随后 N 行,每行按以下格式描述一个结点:

地址 键值 下一个结点

其中地址是该结点的地址,键值是绝对值不超过1的整数,下一个结点是下个结点的地址。

输出格式:

首先输出去重后的链表,然后输出被删除的链表。每个结点占一行,按输入的格式输出。

输入样例:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

输出样例:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
#include<bits/stdc++.h>
using namespace std;
const int maxx = 100100;
struct Node
{
        int Key;
        int Next;
}a[maxx];
int b[maxx];
int main()
{
         int flag[10005];
         memset(flag,0,sizeof(flag));
         int first ,N ,value, m ,add;
         cin>>first>>N;
         for(int i=0;i<N;i++)
         {
               cin>>add;
               cin>>a[add].Key>>a[add].Next;
         }
         m=first;
         value=abs(    a[m].Key  )    ;
         printf("%05d %d",first,a[m].Key);
          flag[value]=1;
         int   count=0;
         while(1)
         {
               m=a[m].Next;
            if(m==-1)
            {
                cout<<" -1"<<endl;
                break;
            }
            value=abs(a[m].Key);
            if(flag[value]==0)
            {
                printf(" %05d\n%05d %d",m,m,a[m].Key);
                flag[value]=1;
             }
            else
            {
                b[count]=m;
                count++;
            }
     }
     if(count>0)
     {
        printf("%05d %d",b[0],a[b[0]].Key);
        for(int i=1;i<count;i++)
        {
            printf(" %05d\n%05d %d",b[i],b[i],a[b[i]].Key);
        }
        cout<<" -1"<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/shengge-777/p/10398948.html