UVA10420 List of Conquests【map】

In Act I, Leporello is telling Donna Elvira about his master’s long list of conquests:
    “This is the list of the beauties my master has loved, a list I’ve made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.” (Madamina, il catalogo questo)
    As Leporello records all the “beauties” Don Giovanni “loved” in chronological order, it is very troublesome for him to present his master’s conquest to others because he needs to count the number of “beauties” by their nationality each time. You are to help Leporello to count.
Input
The input consists of at most 2000 lines. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.
Output
The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.
Sample Input
3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna
Sample Output
England 1
Spain 2

问题链接UVA10420 List of Conquests
问题简述:(略)
问题分析
    简单的单词统计问题,使用STL容器map来实现。map具有key排序的功能。把国家名字统计一下,用STL迭代器输出结果即可。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10420 List of Conquests */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n;
    string country;
    map<string, int> m;

    cin >> n;
    while(n--) {
        cin >> country;
        m[country]++;
        getline(cin, country);
    }
    for(map<string, int>::iterator iter = m.begin(); iter != m.end(); iter++)
        cout << iter->first << " " << iter->second << endl;

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10389728.html