设置IE浏览器文档模式版本

浏览器版本问题是所有开发web的程序员共同的诟病,尤其是IE浏览器,笔者上次修改公司的一个项目中出现项目是在IE9没有出来之前,而现在修改时,则发现页面上出现的表格的错乱(因为表格是通过js动态生成的比较复杂的表格)。

我们可以使用通过几行代码来巧妙的将客户端的浏览器强制以指定版本的(注意这里只能向下兼容)文档模式展示我们的页面;

下面以asp.net程序来说的

在每个需要加此设置的的页面中添加

在Head下添加:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

  

猜你喜欢

转载自www.cnblogs.com/yachao1120/p/10374194.html
0条评论
添加一条新回复