Ubuntu18.10下安装Qt5.12过程记录

首先你得先安装Ubuntu操作系统(我是在VMWare14中安装的Ubuntu18.10版本)。

阿里镜像:https://opsx.alibaba.com/mirror

我这里下载的文件为:ubuntu-18.10-desktop-amd64.iso

VMWare安装Ubuntu18.10过程省略…

打开Ubuntu虚拟机,打开火狐浏览器,输入网址下载QT5.12(linux版本,约13.G)

download.qt.io/archive/qt/5.12/5.12.0/

文件默认下载在Downloads文件夹下

打开终端:

 

切换到Dwownloads目录,输入安装命令:sudo ./qt-opensource-linux-x64-5.12.0.run

但是会提示命令找不到,重新输入:

chmod a+x qt-opensource-linux-x64-5.12.0.run

./qt-opensource-linux-x64-5.12.0.run

此时成功执行,弹出安装对话框界面。

紧接着,根据安装向导一步步执行即可!

可以使用QT Creater了~

但是直接编译程序却报错了:

安装完成后还需要一些配置

由于ubuntu18.10自带qt,但是开发用到的Qt版本是5.12,所以要修改环境配置。网上有很多教程,动不动就修改/etc/profile或者/usr/lib/x86_64-linux-gnu/qt-default/qtchooser/文件,我个人认为要学会用工具,不能这么粗暴的修改系统文件配置,不然系统很容易奔溃。。

话有点多,主要是网上找了很多教程都太老了,最后才找到满意的。

这里用到的是系统自带的qtchooser工具(如果没有请安装)。

通过命令qtchooser -l 可以查看具体命令

添加qt5.12配置,执行命令如下:

此时再执行qmake –v

安装编译器g++:sudo apt-get install build-essential(时间比较长)

安装通用字体配置库:sudo apt-get install libfontconfig1

配置编译器:

此时编译仍然会报错:

安装OpenGL库:

sudo apt-get install mesa-common-dev

    对于新版本的Ubuntu系统,还需要安装附加的package:

    sudo apt-get install libglu1-mesa-dev -y

到此为止,就可以成功编译了~

感谢:https://wiki.qt.io/Install_Qt_5_on_Ubuntu

猜你喜欢

转载自www.cnblogs.com/MakeView660/p/10372772.html
0条评论
添加一条新回复