PAT C语言入门题目-7-43 Shuffling Machine (20 分)

7-43 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

要求:洗牌,输入洗牌次数和每次洗完期望【1,54】张牌放置的位置 ,按最终次序输出这54张牌。

思路:需要一个存放位置的数组pos[],一个存放牌的数组card,一个暂存每次洗牌结果的临时数组recard[],刚开始想到用char 数组来存储牌,但那样不方便操作,于是用了一个调用函数,还要注意一下最后输出的格式问题

#include<stdio.h>
#define NUM 54
void ret(int a)
{
	int flag = a/13;
	if(0 == flag)
		printf("S");
	else if(1 == flag)
		printf("H");
	else if(2 == flag)
		printf("C");
	else if(3 == flag)
		printf("D");
	else if(4 == flag)
		printf("J");
    printf("%d ", a%13+1);
}

int main()
{
	int n;
	int pos[NUM];
	int card[NUM];
	int recard[NUM];
	while( scanf("%d", &n) != EOF )
	{
		for(int i = 0; i < NUM; ++i)
		{
			
			card[i] = i;
			scanf("%d", &pos[i]);
		}
		//shuffling
		while(n--)
		{
			
			for(int i = 0; i < NUM; ++i)//每洗一次牌都重新赋值 
				recard[i] = card[i];
			for(int i = 0; i < NUM; ++i)
				card[pos[i]-1] = recard[i]; 
		}
		//output
		for(int i = 0; i < NUM; ++i)
		{
		    ret(card[i]);
			if(i != NUM-1)
				printf(" ");
			else
				printf("\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37503890/article/details/86601460
今日推荐