1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

哈希表的查找长度

先是输入三个数,msize,n,m,但是要确保msize必须是个素数 ,因此msize不是素数的话就变为大于输入值最小的素数。

把n个数插入哈希表,按照平方探测的方法,不能插入的话按格式输出,查找输入的m个数,求出平均查找长度

#include<bits/stdc++.h>
using namespace std;
bool isPrime(int n)
{
    if(n==0||n==1)
        return false;
    for(int i=2;i*i<=n;i++)
        if(n%i==0)
        return false;
    return true;
}
int main()
{
    int msize,n,m,x;
    cin>>msize>>n>>m;
    while(!isPrime(msize))
        msize++;
    vector<int>v(msize);
    for(int i=0;i<n;i++)
    {
        int flag=0;
        cin>>x;
        for(int j=0;j<msize;j++)
        {
            if(v[(x+j*j)%msize]==0)
            {
                v[(x+j*j)%msize]=x;
                flag=1;
                break;
            }
        }
        if(!flag)
            cout<<x<<" cannot be inserted."<<endl;
    }
    double sum=0.0;
    for(int i=0;i<m;i++)
    {
        cin>>x;
        for(int j=0;j<=msize;j++)
        {
            sum++;
            if(v[(x+j*j)%msize]==x||v[(x+j*j)%msize]==0)
                break;
        }
    }
    printf("%.1f",sum/m);
    return 0;

猜你喜欢

转载自blog.csdn.net/x_zjudream/article/details/86503773