1040 Longest Symmetric String (25 分)(C++)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

求最长回文串,有很多经典的算法

算法一:中心扩展法,比较好理解的算法之一,就是以s串的字符为遍历对象,结果回文串相对于每个字符只有两种可能,一种是奇对称,一种偶对称,所以再分两种情况,比较两种情况下的最大回文串的长度。

#include <iostream>
#include <string>
using namespace std;
string s;
int result=0,len;
void expandaroundcenter(int left,int right){
    while(left>=0&&right<len&&s[left]==s[right]){
        left--;right++;
    }
    result=max(right-left-1,result);
}
int main(){
    getline(cin,s);
    len=s.length();
    for(int i=0;i<len;i++){
        expandaroundcenter(i,i);
        expandaroundcenter(i,i+1);
    }
    printf("%d",result);
}

算法二:Manancher算法

貌似有个测试点用了‘#’,emmmm所以取特殊字符的时候要留意

#include <iostream>
#include <string>
#include <vector>
using namespace std;
string s,s2,temp;
int result=0,len,len2;
int main(){
    getline(cin,s);
    len=s.length();
    s2+='@';
    for(int i=0;i<len;i++)
        s2=s2+'!'+s[i];
    s2+="!$0";
    len2=s2.length();
    std::vector<int> Len(len2,0);
    int mx=0,po=0;
    for(int i=0;i<len2;i++){
        if(mx>i)
            Len[i]=min(mx-i,Len[2*po-i]);
        else
            Len[i]=1;
        while(s2[i-Len[i]]==s2[i+Len[i]])
            Len[i]++;
        if(Len[i]+i>mx){
            mx=Len[i]+i;
            po=i;
        }
        if(Len[i]>result){
            result=Len[i];
            temp=s.substr(i-Len[i]+1,2*Len[i]-1);
        }
    }
    for(int i=0;i<temp.length();i++)
        if(temp[i]=='!')
            result--;
    printf("%d",result-1);
}

算法三:动态规划

#include <iostream>
#include <string>
using namespace std;
string s;
bool dp[1010][1010];
int len,result;
int main(){
    getline(cin,s);
    len=s.length();
    fill(dp[0],dp[0]+1010*1010,false);
    for(int i=0;i<s.length();i++){
        dp[i][i]=true;
        if(i!=len-1&&s[i]==s[i+1]){
            dp[i][i+1]=true;
            result=2;
        }
    }
    for(int k=3;k<=len;++k)
        for(int i=0;i+k-1<len;i++)
            if(s[i]==s[i+k-1]&&dp[i+1][i+k-2]==true){
                dp[i][i+k-1]=true;
                result=k;
            }
    printf("%d",result);
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/86475894