PAT 乙级1012

1012 数字分类 (20 分)

给定一系列正整数,请按要求对数字进行分类,并输出以下 5 个数字:

A​1​​ = 能被 5 整除的数字中所有偶数的和;
A​2​​ = 将被 5 除后余 1 的数字按给出顺序进行交错求和,即计算 n​1​​−n​2​​+n​3​​−n​4​​⋯;
A​3​​ = 被 5 除后余 2 的数字的个数;
A​4​​ = 被 5 除后余 3 的数字的平均数,精确到小数点后 1 位;
A​5​​ = 被 5 除后余 4 的数字中最大数字。

输入格式:

每个输入包含 1 个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N,随后给出 N 个不超过 1000 的待分类的正整数。数字间以空格分隔。

输出格式:

对给定的 N 个正整数,按题目要求计算 A​1​​~A​5​​ 并在一行中顺序输出。数字间以空格分隔,但行末不得有多余空格。

若其中某一类数字不存在,则在相应位置输出 N。

输入样例 1:

13 1 2 3 4 5 6 7 8 9 10 20 16 18

输出样例 1:

30 11 2 9.7 9

输入样例 2:

8 1 2 4 5 6 7 9 16

输出样例 2:

N 11 2 N 9

坑点

对于A2这样数字的统计

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv) {
	
	int N;
	scanf("%d",&N);
	int A1=0,A2=0,A3=0,A5=0;
	int A4=0,countA2=0;
	int temp,i=0,countA3=0,maxA5=0;
	int countA4=0;
	while(N--)
	{
		scanf("%d",&temp);
		
		if(temp%5==0 && temp%2==0)
			A1+=temp;
		else if(temp%5==1)
		{
			countA2++;
			if(i%2==0)
				A2+=temp;

			else
				A2-=temp;
			i++;
				
		}
		else if(temp%5==2)
			countA3++;

		else if(temp%5==3)
		{
			countA4++;
			A4+=temp;

		}
		else if(temp%5==4)
		{
			if(temp>maxA5)
				maxA5=temp;

		}
	}

	printf("%s ",A1==0?"N":to_string(A1).c_str());
	printf("%s ",countA2==0?"N":to_string(A2).c_str());
	printf("%s ",countA3==0?"N":to_string(countA3).c_str());

	if(countA4==0)
		printf("N ");
	else 
		printf("%.1f ",A4*1.0/countA4);
	printf("%s",maxA5==0?"N":to_string(maxA5).c_str());

	return 0;
}

猜你喜欢

转载自blog.csdn.net/DoctorLDQ/article/details/86355689