1057 Stack (30 分)树状数组求堆栈中位数

版权声明:假装这里有个版权声明…… https://blog.csdn.net/CV_Jason/article/details/85239766

题目

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N ( 1 0 5 ) N (≤10^5) . Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 1 0 5 10^5 .

Output Specification:
For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

解题思路

  题目大意: 给你一个堆栈,有3种指令,第一个指令Pop,即出栈,第二个指令 Push key,即压栈,第三个指令,PeekMedian 查询堆栈中位数。
  解题思路: 这道题的难点如何确定中位数,如果对堆栈做排序,肯定会超时的。这里介绍一种树状数组的方法,详情见代码——


#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
using namespace std;
 
const int maxn = 100001;
int c[maxn] = {0};
 
int lowbit(int n){
	return n & (-n);
} 
 
void update(int i,int val){
	while(i <= maxn){
		c[i] += val;
		i += lowbit(i);
	}
} 
 
int getsum(int i){
	int sum = 0;
	while(i > 0){
		sum += c[i];
		i -= lowbit(i);
	}
	return sum;
}
 
int Bsearch(int num){
	int l = 0,r = maxn-1,mid;
	while(l < r){
		mid = (l + r) / 2;
		int n = getsum(mid);
		//注意这里不能用n == num并返回mid,因为树状数组的c[i]是块状之和,部分sum[i]的值可能一样 
		//所以必须是一直向左移动获得最少的sum[i]下标 
		if(n >= num)
			r = mid;
		else
			l = mid + 1;
	}
	return r;
}
 
 
int main(){
	int n;
	scanf("%d",&n);
	char ch[11] = {0};
	stack<int> s;
	for(int i=0;i<n;i++)
	{
		scanf("%s",ch);
		if(ch[1] == 'e'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				int num = s.size();
				if(num%2 == 0)
					num = num / 2;
				else
					num = (num+1) / 2;
				printf("%d\n",Bsearch(num));
			}
		}
		else if(ch[1] == 'o'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				printf("%d\n",s.top());
				update(s.top(),-1);
				s.pop();
			}
		}
		else{
			int a;
			scanf("%d",&a);
			s.push(a);
			update(s.top(),1);
		}
	}
	
	return 0;
}

在这里插入图片描述

题目

  哀吾生之须臾,羡长江之无穷。这道题完全不会做,挺难的。

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/85239766
今日推荐