B1033 旧键盘打字

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及坏掉的那些键,打出的结果文字会是怎样?

输入格式:

输入在 2 行中分别给出坏掉的那些键、以及应该输入的文字。其中对应英文字母的坏键以大写给出;每段文字是不超过 10​5​​ 个字符的串。可用的字符包括字母 [a-zA-Z]、数字 0-9、以及下划线 _(代表空格)、,.-+(代表上档键)。题目保证第 2 行输入的文字串非空。

注意:如果上档键坏掉了,那么大写的英文字母无法被打出。

输出格式:

在一行中输出能够被打出的结果文字。如果没有一个字符能被打出,则输出空行。

输入样例:

7+IE.
7_This_is_a_test.

输出样例:

_hs_s_a_tst
#include<stdio.h>
#include<string.h>
int main(){
	bool hashTable[100100];
	memset(hashTable,true,sizeof(hashTable));
	char str1[100100],str2[100100];
	fgets(str1,sizeof(str1),stdin);scanf("%s",str2);
	int len1=strlen(str1);
	int len2=strlen(str2);
	int local=0;
	for(int i=0;i<len1;i++){
		hashTable[str1[i]]=false;
		if('A'<=str1[i]&&str1[i]<='Z'){hashTable[str1[i]-'A'+'a']=false;}
		if('a'<=str1[i]&&str1[i]<='z'){hashTable[str1[i]-'a'+'A']=false;}
	}
	for(int i=0;i<len2;i++){
		if(hashTable['+']==false){
			if('A'<=str2[i]&&str2[i]<='Z')continue;
			if(hashTable[str2[i]]==true) 
				{printf("%c",str2[i]);local++;}
		}
		else
		{
			if(hashTable[str2[i]]==true)
				{printf("%c",str2[i]);local++;}
		}
	}
	if(local==0)printf("\n");
	return 0;
}

 注意:有个能str1为空 如果用scanf()输入的话 识别不了空 只能用fgets

猜你喜欢

转载自blog.csdn.net/weixin_42127158/article/details/82154214