1027 Colors in Mars (20 分)【10进制转换为13进制】

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题意:给出三个10进制的数字,将其转换为13进制的数据

解题思路:168对13进制来说最多2位,直接定义一个r[]="0123456789ABC",第一位就是取下标为数字除以13的字符,第二个字符就是取下标为数字取余13的 字符

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	char r[]="0123456789ABC";
	int a,b,c;
	scanf("%d %d %d",&a,&b,&c);
	printf("#");
	printf("%c%c%c%c%c%c",r[a/13],r[a%13],r[b/13],r[b%13],r[c/13],r[c%13]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/84036265