PAT (Advanced Level) Practice 1019 General Palindromic Number (20 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85766847

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​ (a​ib​i). Here, as usual, 0≤a​i<bfor all i and a​k is non-zero. Then N is palindromic if and only if a​i​​ =a​k−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k a​k−1… a0 ". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
Sample Output 1:

Yes
1 1 0 1 1
Sample Input 2:

121 5
Sample Output 2:

No
4 4 1
鸣谢网友“CCPC拿不到牌不改名”修正数据!


#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int N = 0, b = 0;
	scanf("%d %d", &N, &b);
	if (!N)//输入为0单独考虑,直接输出即可
	{
		printf("Yes\n0");
		return 0;
	}
	int S[50] = { 0 }, top = -1;//辅助栈
	while (N)//把N转化为b进制数存储在栈中
	{
		S[++top] = N % b;
		N /= b;
	}
	int flag = 1;//判断是否是回环数的标志
	for (int i = 0; i <= top / 2; i++)//注意条件
	{
		if (S[i] != S[top - i])
		{
			flag = 0;//有一个不匹配即跳出即可
			break;
		}
	}
	if (flag) printf("Yes\n");
	else printf("No\n");
	printf("%d", S[top--]);//输出时控制格式
	while (top >= 0) printf(" %d", S[top--]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85766847
今日推荐