D-Problem D

D-Problem D

给定三条边,请你判断一下能不能组成一个三角形。

Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;

Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。

Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES

问题分析:
该题注意的是A,B,C为正数,代表可以为浮点数,所以要用double 而不是int,注意输出的yes和no为大写形式。

#include<iostream>
using namespace std;
int main()
{
	int M,i;
    cin>>M;
	double A,B,C; 
	while(M--)
	{
	cin>>A>>B>>C;
	if(A+B>C&&B+C>A&&A+C>B)
	cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
}
	

}

猜你喜欢

转载自blog.csdn.net/weixin_43971913/article/details/84900777
d
<d>