1035 Password (20 分)字符串处理(水题)

版权声明:emmm……我也想成为大佬 https://blog.csdn.net/CV_Jason/article/details/84961618

题目

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

解题思路

  题目大意: 给你N个用户名和密码,要求把1转换成@,0 转换成%,l(L的小写)转换成L,O转换成o。
  解题思路: 没啥弯弯绕绕的,直接挨个判断就行了,注意最后的输出就好 。

/*
** @Brief:No.1035 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2018-12-11 
** @status: Accepted!
*/
#include<iostream>
#include<string>
using namespace std;

struct user{
	string name;
	string passWord;
	bool haveModified;
} users[1001];

bool modified(int i){
	users[i].haveModified = false;
	for(auto it = users[i].passWord.begin();it!=users[i].passWord.end();it++){
		switch(*it){
			case '1':*it = '@',users[i].haveModified = true;break;
			case 'l':*it = 'L',users[i].haveModified = true;break;
			case '0':*it = '%',users[i].haveModified = true;break;
			case 'O':*it = 'o',users[i].haveModified = true;break; 
		}
	}
	return users[i].haveModified;
}

int main(){
	int N;
	int count = 0;
	cin>>N;
	for(int i=0;i<N;i++){
		cin>>users[i].name>>users[i].passWord;
		if(modified(i))
			count++;
	}
	if(count){
		cout<<count<<endl;
		for(int i=0;i<N;i++){
			if(users[i].haveModified){
				cout<<users[i].name<<" "<<users[i].passWord<<endl;
			}
		}
	}else{
		if(N==1){
			cout<<"There is 1 account and no account is modified"<<endl;
		}else{
			cout<<"There are "<<N<<" accounts and no account is modified"<<endl;
		}
		
	}
	return 0;
}

在这里插入图片描述

总结

  第一道题还是舒服,10分钟写完了。

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/84961618