Jolly Jumpers_UVA10038

题目

 A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance, 1 4 2 3 is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper. Input Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence. Output For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’. Sample Input 4 1 4 2 3 5 1 4 2 -1 6 Sample Output Jolly Not jolly

题目大意

eof输入

首先输入n,表示有n个数字。

然后判断每两个相邻数字的绝对值是否在(0,n)范围内,并且要求这些绝对值覆盖整个(0,n)区间

 算法: 贪心

 代码

#include <iostream>
#include <algorithm>
using namespace std;
int a[3005],b[3005]; 
int main()
{
	int n,i;
	while(cin>>n)
	{
		for(i=0;i<n;i++)
		{
			cin>>a[i];                        //数据输入到a中
		}	
		for(i=0;i<n-1;i++)                 //b用来存储相邻元素的绝对值
		{
			b[i+1]=abs(a[i]-a[i+1]);
		}
		sort(b+1,b+n);  //将绝对值数字排序
		for(i=1;i<=n-1;i++)
		{
			if(b[i]!=i)	break;            //看绝对值是否覆盖整个(0,n)区间 
		}                      
		if(i==n)                          //如果上一个绝对值判断循环正常结束
                                          //说明判断完了最后一个 那么全覆盖了
		cout<<"Jolly"<<endl;
		else
		cout<<"Not jolly"<<endl;            // <n说明中间break退出了 那么没有全部覆盖 
	}    
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_41907100/article/details/84825030