zoj 3846 GCD Reduce

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34621169/article/details/51145961
GCD Reduce

Time Limit: 2 Seconds       Memory Limit: 65536 KB       Special Judge

You are given a sequence {A1A2, ..., AN}. You task is to change all the element of the sequence to 1 with the following operations (you may need to apply it multiple times):

  • choose two indexes i and j (1 ≤ i < j ≤ N);
  • change both Ai and Aj to gcd(AiAj), where gcd(AiAj) is the greatest common divisor of Ai and Aj.

You do not need to minimize the number of used operations. However, you need to make sure that there are at most 5N operations.

Input

Input will consist of multiple test cases.

The first line of each case contains one integer N (1 ≤ N ≤ 105), indicating the length of the sequence. The second line contains N integers, A1A2, ..., AN (1 ≤ Ai ≤ 109).

Output

For each test case, print a line containing the test case number (beginning with 1) followed by one integer M, indicating the number of operations needed. You must assure that M is no larger than 5N. If you cannot find a solution, make M equal to -1 and ignore the following output.

In the next M lines, each contains two integers i and j (1 ≤ i < j ≤ N), indicating an operation, separated by one space.

If there are multiple answers, you can print any of them.

Remember to print a blank line after each case. But extra spaces and blank lines are not allowed.

Sample Input

4
2 2 3 4
4
2 2 2 2

Sample Output

Case 1: 3
1 3
1 2
1 4

Case 2: -1



给出n个数字,然后通过gcd使得全部的数字变为1.输出方法需要的步骤和方法;
思路:n个数gcd如果是1的话,那就可以全部数字和1gcd一遍然后搞出那个1,然后再gcd一遍就好了;
否则是搞不出1的;



AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int gcd(int a,int b){
    if(a<b)
        swap(a,b);
    while(b!=0){
        int r=b;
        b=a%b;
        a=r;
    }
    return a;
}
int main(){
    int n,a[500008],order=1;
    while(cin>>n){
        for(int i=0;i<n;i++)
            cin>>a[i];
    int tmp=a[0];
    for(int i=1;i<n;i++)
        tmp=gcd(tmp,a[i]);
        if(tmp!=1){
            printf("Case %d: -1\n\n",order++);
        }
        else{
            printf("Case %d: %d\n",order++,2*(n-1));
            for(int i=2;i<=n;i++)
                printf("1 %d\n",i);
            for(int i=2;i<=n;i++)
                printf("1 %d\n",i);
            cout<<endl;
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_34621169/article/details/51145961
ZOJ
gcd